Weird clutch feel

View previous topic View next topic Go down

Weird clutch feel

Post by JF74chevelle on Sat Jun 17, 2017 5:44 pm

So just now I drove from my girlfriends house to mine about 2.5 miles. In the beginning th clutch pedal felt amazing (no binding, nice smooth shifts) then towards the end of the drive the clutch pedal started to bind and not feel as smooth. Luckily I made it home then when the car was shut of I pushed in he clutch pedal and POP some linkage problem occurred and the pedal sagged. Took a gander and saw that the clutch rod adjuster came out of the groove in the clutch fork. How could this even happen? I have a spring pulling good tension on it. Any help would be nice. Thank you-Justin
avatar
JF74chevelle
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: Weird clutch feel

Post by clanceman427 on Sat Jun 17, 2017 7:17 pm

First let me ask if the adjuster is still bolted to the Z bar?  If so, then I'd guess the adjuster was adjusted with a little too much free play and the clutch pedal return spring doesn't need to be too strong just enough to keep the pedal and z bar off the clutch fork while the clutch is released to isolate vibration from the pedal assembly and keep any pressure off the throw out bearing.  The stock pedal return spring is not all that big.
avatar
clanceman427
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 14

Back to top Go down

Re: Weird clutch feel

Post by JF74chevelle on Sat Jun 17, 2017 11:18 pm

clanceman427 wrote:First let me ask if the adjuster is still bolted to the Z bar?  If so, then I'd guess the adjuster was adjusted with a little too much free play and the clutch pedal return spring doesn't need to be too strong just enough to keep the pedal and z bar off the clutch fork while the clutch is released to isolate vibration from the pedal assembly and keep any pressure off the throw out bearing.  The stock pedal return spring is not all that big.

Yes the adjuster was still intact with the z-bar
avatar
JF74chevelle
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: Weird clutch feel

Post by clanceman427 on Sun Jun 18, 2017 6:20 am

Sorry I just realized I did not explain that correctly. The pedal return spring should be holding the clutch fork, adjuster, z bar, and pedal assembly back off the throw out bearing when clutch is released. The spring runs from behind the clutch fork to the frame near the brake distribution block.

Things to check would be:
-is the clutch fork still properly centered on its pivot ball which is screwed to the bellhousing?
-is pivot ball broken?
-is z-bar still properly oriented in frame and on the engine block?
-If nothing in the entire linkage is messed up perhaps you broke a motor mount on the drivers side?
avatar
clanceman427
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 14

Back to top Go down

Re: Weird clutch feel

Post by JF74chevelle on Sun Jun 18, 2017 7:35 pm

All it was is the adjuster rod being loose. Tightened it and moved it to the top hole on the z-bar and it feels WAY better. Thank you for the help!!
avatar
JF74chevelle
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: Weird clutch feel

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum