screwed up jump starting...

Go down

screwed up jump starting...

Post by Daves'77 BU on Fri Jul 07, 2017 7:44 pm

so...I killed my battery by leaving the dome light on...was jumping it with my truck...it wouldnt start, but would crank...I was watching my 12 year old dog and 5 y.o. child and inadvertently hooked up cables wrong and noticed when wires from alternator were getting hot and started to smoke...I put battery on charger, car started once. I shut it off and I now have no power at all. I have never ever ever done this. Where do I start to troubleshoot? The battey has a full charge...Dave
avatar
Daves'77 BU
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: screwed up jump starting...

Post by 73ss on Fri Jul 07, 2017 9:41 pm

Should be some fusible links off the main pos stud on the starter that feed the main harness, most likely melted apart. you should think about replacing the harness at some point. wonder if the alternator got smoked as well?
avatar
73ss
G3GM Member
G3GM Member

Street Cred : 10

Back to top Go down

Re: screwed up jump starting...

Post by REVINKEVIN on Fri Jul 07, 2017 9:47 pm

Like 73 SS says, check the fusible link. Do you have a volt meter? You can check to see if it has burned out. It should have. If you are lucky, and I think you will be, it did it's job and protected they other circuits.
avatar
REVINKEVIN
G3GM Member
G3GM Member

Street Cred : 11

Back to top Go down

Re: screwed up jump starting...

Post by Daves'77 BU on Sat Jul 08, 2017 11:40 am

i will check those links...what do I replace it with...

avatar
Daves'77 BU
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: screwed up jump starting...

Post by Daves'77 BU on Sat Jul 08, 2017 12:18 pm

if that link is blown, there would be no power at all to anything correct?
avatar
Daves'77 BU
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: screwed up jump starting...

Post by 73ss on Sat Jul 08, 2017 3:29 pm

Daves'77 BU wrote:if that link is blown, there would be no power at all to anything correct?

correct. Some part stores carry replacement lengths. You'll probably want to pull the starter off to get at them.
avatar
73ss
G3GM Member
G3GM Member

Street Cred : 10

Back to top Go down

Re: screwed up jump starting...

Post by crice63 on Sun Jul 09, 2017 3:33 pm

The fusible link should be four gauge sizes smaller than the wire it protects. The 14 gauge one carried by the parts stores is basically correct. I think someone had rewired mine so I had some challenges replacing it, took the opportunity to put in a ford solenoid setup. The thread detailing my tribulations is at the El Camino site:
http://www.elcaminocentral.com/showthread.php?t=197210

Skip to the last post if you just want to see the setup.

crice63
Donating Member
Donating Member

Street Cred : 1

Back to top Go down

Re: screwed up jump starting...

Post by Daves'77 BU on Sun Jul 09, 2017 11:20 pm

Hi...Found my fusible link to solenoid burnt...changed it, car starts, runs, let it run for 45 mins and it didnt burn up, woohoo !!! thanks guys for your help !!! Dave
avatar
Daves'77 BU
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: screwed up jump starting...

Post by pila on Mon Jul 10, 2017 7:21 am

Your fusible link did it's job, just what it was in there for ! Very Happy

pila
Donating Member
Donating Member

Street Cred : 43

Back to top Go down

Re: screwed up jump starting...

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum