TH350 Transmission problems with shifting

View previous topic View next topic Go down

TH350 Transmission problems with shifting

Post by rogal_tx on Tue Aug 16, 2011 8:21 am

I got 73 Malibu (project car) that I just gotting running past weekend but not the way I want to. Transmission want shift automaticaly but I can shift manualy.
Anyone had same problem? any suggestions on what to do?
Thanks
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by The Dude on Tue Aug 16, 2011 10:44 am

Got a few ideas spinning here, so let's see if we can fix you up.

First off, how long has the trans been sitting & does it have a new filter/fluid? Might be worn out bands, a clogged filter, or bad fluid. Could just be the valve body sticking from sitting so long.

Second, check your vacuum lines. TH350s don't like to shift right if the modulator is unhooked or bad.

It's also possible that you need a new governor if the above suggestions fail.
avatar
The Dude
Management
Management

Street Cred : 48

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by oldstofty on Tue Aug 16, 2011 11:42 am

Have you used this trans before or was it in the car when purchased? It may be a manual valve body which of couse would be aftermarket but just an idea
avatar
oldstofty
G3GM Member
G3GM Member

Street Cred : 6

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Tue Aug 16, 2011 11:54 am

when I got the car it was sitting for probably 2 years and not running.
Put new fluid and filter, just replaced vacuum modulator last night (will test drive it today)

FYI: It appears car was drag racing car so manual valve body sounds like possibility.

Will post update later today after i test drive it.
Thanks
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by oldstofty on Tue Aug 16, 2011 1:09 pm

Ya if it was set up as a race car, more than likely its a manual valve body
avatar
oldstofty
G3GM Member
G3GM Member

Street Cred : 6

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Tue Aug 16, 2011 4:11 pm

also seems like transmission want stop leaking oil, I replaced the pan seal twice and then replaced the pan because that didn't solve the problem. After all that it stoped leaking till first test drive and it leaks from passanger front side.

Does the manual valve body keeps higher pressure (gauge shows 35psi - 40 psi) at all times? Could that be a cause??

My another 73 Malibu reads between 40 and 60 psi and it doesn't leaks so I don't think its a problem but I figure I ask.
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by abajc3 on Tue Aug 16, 2011 6:15 pm

manual valve body seems the most probable cause to me, i had a failed governor once and it wouldnt upshift no matter what.

as for the leakage part, check that the mating surface on the tranny case isnt dented or sth like that. i had that happen once with an aluminium intake that someone probably dropped on the floor. it wouldnt compress the sealant properly and i can assure you that car was leaking oil like crazy. filed that edge off and its fine now.

abajc3
G3GM Member
G3GM Member

Street Cred : 3

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by lagunainnewark on Tue Aug 16, 2011 8:15 pm

Passenger front corner could also be cooler lines or dip stick tube seal, Good luck, Ron
avatar
lagunainnewark
G3GM Member
G3GM Member

Street Cred : 8

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Wed Aug 17, 2011 8:42 am

Surprisingly enough vacuum line modulator was a problem to shifting, replaced it and shifts good,(so no manual valve body) but I'm still fighting the leak. I jacked up the right side of the car to look at it and it was wet in front and right side of the pan as well as on top of the transmission housing around dipstick and kick down cable.
I will replace dipstick and kick down cable o-rings today.
Also, rear of the car sits substantially higher than the front so fluid would travel to the front of the pan before dripping, anything towards the back side of the trans. that could cause the leak?
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by texan01 on Wed Aug 17, 2011 8:51 pm

Mine leaks from there as well, and I've replaced everything that can seal right there. I think my pan is warped. I even replaced the dipstick tube with a new one with the cup seal instead of the oring, new kickdown cable since mine was broken, and teflon tape on the cooler lines, not going into the case, just into the adapters.

texan01
G3GM Member
G3GM Member

Street Cred : 6

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by abajc3 on Thu Aug 18, 2011 3:56 am

have any of you tried silicone gasket maker? i think it should compensate for irregularities in the mating surfaces more than the normal gasket. might do the trick i guess

abajc3
G3GM Member
G3GM Member

Street Cred : 3

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Thu Aug 18, 2011 8:33 am

This is harder then I thought, I cleaned the right side of the trans, took it on the road put it on jack stands to look for leaks. Didn't see anything so I lefted on jack stand over night hoping it will show.
Next day, right side completely dry but since left side was sitting lower it started to leak. It doesn't appear that pan is the problem but I don't know anymore.
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by Limey SE on Thu Aug 18, 2011 9:54 am

could it be a hairline crack in the housing ???

___________________________________________
avatar
Limey SE
Management
Management

Street Cred : 85

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by 74Malibu383 on Thu Aug 18, 2011 11:47 am

Front seal?
avatar
74Malibu383
Donating Member
Donating Member

Street Cred : 26

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Thu Aug 18, 2011 12:01 pm

Limey wrote:could it be a hairline crack in the housing ???
That will be impossible to find
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by rogal_tx on Thu Aug 18, 2011 12:02 pm

74Malibu383 wrote:Front seal?
and tips how to replace it or check if thats whats leaking?
avatar
rogal_tx
G3GM Member
G3GM Member

Street Cred : 0

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by 74Malibu383 on Thu Aug 18, 2011 12:07 pm

You have to pull the tranny and take the torque converter off. If it's leaking, you'll need a seal puller (T-shaped tool with hooks on the end) then you can tap in the new front seal. Make sure it goes in square.
avatar
74Malibu383
Donating Member
Donating Member

Street Cred : 26

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by pila on Fri Aug 19, 2011 12:08 am

Maybe the seal in the shifter selector shaft is seeping, where it goes through the case. Had that problem once....

pila
Donating Member
Donating Member

Street Cred : 43

Back to top Go down

Re: TH350 Transmission problems with shifting

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum