My update

Go down

My update Empty My update

Post by BlackChevelleSS on Mon Mar 09, 2009 9:11 pm

Hey guys been working my A$$ off lately trying to get my 70 back on the road after the oil pump pickup came off. Well I got the old, but not tired (im tired of it) 396 out and the new 454 installed. This damn thing has fought me throughout the entire build. I got the Huge ported out rectangle ports off the 396 to find 3 guides broken and a stock valve, someone installed. So off to the machine shop for the huge bill of a complete valve job, guide replacement, and a single valve replace. But thats done, got the cam out to find out that my fuel pump ecentric was ate to hell so thats another expense converting to electric pump. The engine was installed, after finding a set of Ceramic coated hooker headers to replace my old painted hookers. Got it in and the new oil pan sat on the crossmember and made contact with the steering center link and inner tie rods. Spaced the engine mounts to get it a tad higher, that took a whole 4-5 hours since the mounts would no longer line up. Beat in the new oil pan to clear the steering and removed the grease zirks to stop from punching a hole in it.
Well so now on to setting up the fuel system, the damn POS holley pump leaks and the internal regulator stuck and blew up my other regulator. So after 2 days of fighting with that I gave up and installed a dinky electric we had laying around. Gave it enough fuel to fire up today so It does run, still got quite a bit to do but hopefully in a couple days itll be going.

___________________________________________
www.cardomain.com/id/3115ultima

My update SIG2
BlackChevelleSS
BlackChevelleSS
Management
Management

Street Cred : 20

Back to top Go down

My update Empty Re: My update

Post by JB2wheeler on Tue Mar 10, 2009 6:14 pm

Hang in there, It will get done sooner or later. JB
JB2wheeler
JB2wheeler
G3GM Fanatic
G3GM Fanatic

Street Cred : 28

Back to top Go down

My update Empty Re: My update

Post by BlackChevelleSS on Wed Mar 11, 2009 12:40 am

well I didnt mess with it today and didnt have a headache amazingly. But went down and fired it up agian looked down and had no oil pressure. Got out and looked, all 6 qts of oil on the ground. WTF? I just dont know didnt feel like looking for the problem so just shut it up and left it.

___________________________________________
www.cardomain.com/id/3115ultima

My update SIG2
BlackChevelleSS
BlackChevelleSS
Management
Management

Street Cred : 20

Back to top Go down

My update Empty Re: My update

Post by IndyG3 on Wed Mar 11, 2009 2:21 am

Pics or it never happened! Very Happy
IndyG3
IndyG3
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 11

Back to top Go down

My update Empty Re: My update

Post by BlackChevelleSS on Wed Mar 11, 2009 2:45 am

maybe ill get the urge to look at it agian in a few days and get some pics then.

___________________________________________
www.cardomain.com/id/3115ultima

My update SIG2
BlackChevelleSS
BlackChevelleSS
Management
Management

Street Cred : 20

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum