It only "just" started making noise!

Page 2 of 3 Previous  1, 2, 3  Next

Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by switchbiker on Tue Mar 25, 2014 11:36 pm

I once showed a customer that his drum brake wheel cylinders were the cause of his brake shoes getting saturated with brake fluid. I pulled back the dust boots and fluid came pouring out. He accused me of "breaking the seal" and stormed off taking his car to another shop.
switchbiker
switchbiker
Donating Member
Donating Member

Street Cred : 3

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by switchbiker on Tue Mar 25, 2014 11:47 pm

A customer had his car towed to my shop because it wouldn't start. I jumped in and it started and ran beautifully. I explained to him that he had an intermittent problem and it would be good practice to run som diagnotics on it to find where the issue was. He declined. The next day he brought the car back and tried to demand we fix it for free because I "told him it would be fine". He lied, I never said that. Thankfully I was great about documenting all requested repairs/ diagnostics on the work orders and brought out the paperwork that he signed to show him.
switchbiker
switchbiker
Donating Member
Donating Member

Street Cred : 3

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Wed Mar 26, 2014 6:21 am

My company has no spine.  Even if we document things, and make customers sign off all they have to do is complain and they start getting free stuff. Mad
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by chevellelaguna on Wed Mar 26, 2014 12:18 pm

Amen we're the same way, unfortunate, as long as I get paid though I don't care.
chevellelaguna
chevellelaguna
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 16

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by BlackChevelleSS on Thu Mar 27, 2014 12:25 am

This one came in the shop today, customer stated that the pedal went to the floor. The piston came out of the caliper. 2000 Chevy 2500hd

It only "just" started making noise! - Page 2 IMAG0223_zps6fe96306

___________________________________________
www.cardomain.com/id/3115ultima

It only "just" started making noise! - Page 2 SIG2
BlackChevelleSS
BlackChevelleSS
Management
Management

Street Cred : 20

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Fri May 02, 2014 8:38 pm

It only "just" started making noise! - Page 2 MG_20140430_132820998_zpsfkjdelkv
This came in yesterday.  Someone had put a home light switch (under the hood) to control the electric fans that didn't work as designed anymore.  We could not figure out why it was not put in the interior.  The whole vehicle was a big POS.  The exhaust was repaired with a chrome exhaust tip rigged in the center to (try) to fix a leak...it didn't work. Laughing
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by 77mali on Fri May 02, 2014 8:46 pm

Looks like a GM ... late 90's Monte or Lumina?
77mali
77mali
Donating Member
Donating Member

Street Cred : 62

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Fri May 02, 2014 8:48 pm

'98 olds silloute mini van.
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by chevellelaguna on Fri May 02, 2014 8:48 pm

LOL, you mean that you don't have one of those on your car?? Buick? 3100/3400?... Yeah has those plastic wing nuts , hate the rad supports on those.


Last edited by chevellelaguna on Fri May 02, 2014 8:50 pm; edited 1 time in total
chevellelaguna
chevellelaguna
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 16

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by 77mali on Fri May 02, 2014 8:49 pm

Same FWD & v6 motor, LOL (and braces!)
77mali
77mali
Donating Member
Donating Member

Street Cred : 62

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Fri May 02, 2014 8:49 pm

I think it was a 3.4.
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by chevellelaguna on Fri May 02, 2014 9:14 pm

You gotta have a new guy in the shop.... I'd bring him over and have someone by the shop light switch... And say.."watch this" flip it and the shop lights go off , and back on! We always mess with each other and the new guy!
chevellelaguna
chevellelaguna
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 16

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Tue Jun 03, 2014 1:17 pm

Here's another...1995 mustang 'vert with the left rear  brake bypassed.  remember no inspection here. Evil or Very Mad 
It only "just" started making noise! - Page 2 IMG_20140603_130041657_zps6nlgzbfcHere's the cut off line..
It only "just" started making noise! - Page 2 IMG_20140603_130058721_zpsbmwhzlxq And here's the bolt to keep it from leaking. Oh and BTW the car was here for an oil change & rotate, "no other problems" according to the customer.


Last edited by dynchel on Tue Jun 03, 2014 1:25 pm; edited 1 time in total (Reason for editing : added details)
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by Mcarlo77 on Tue Jun 03, 2014 3:56 pm

Geez...and I thought we (my buddies and I) were negligent back in the day for cutting the rear parking brake cables when they rusted up!
Mcarlo77
Mcarlo77
Donating Member
Donating Member

Street Cred : 70

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by Wallyuph on Tue Jun 03, 2014 4:56 pm

New form of line lock there.
Wallyuph
Wallyuph
Donating Member
Donating Member

Street Cred : 31

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Thu Sep 11, 2014 1:30 pm

It only "just" started making noise! - Page 2 IMG_20140911_124013376_zpser06chax
This came in today.  These people must have skills  to have a screw puncture there tire with the blunt end.  jocolor
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by driveit on Thu Sep 11, 2014 1:47 pm

I punctured a truck tire on my Z71 silverado a few years back while driving up a gravel road. There was a large pointed rock that went in between the tread. We couldn't get it out. We pushed it through and plugged it. Took like 6 plugs or something lol... I drove it like that for two years before I sold the truck. The rock still inside the tire lol..
driveit
driveit
Donating Member
Donating Member

Street Cred : 15

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by 77mali on Thu Sep 11, 2014 2:10 pm

Was it too far down the sidewall to be saved or can you guys use those awesome "patches" that we can't get in MA anymore?
77mali
77mali
Donating Member
Donating Member

Street Cred : 62

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Thu Sep 11, 2014 2:16 pm

77mali wrote:Was it too far down the sidewall to be saved or can you guys use those awesome "patches" that we can't get in MA anymore?
It got four tires.  We aren't allowed to fix any questionable tire.
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by pila on Thu Sep 11, 2014 5:04 pm

Most places wont use plugs in recent years, because of a major lawsuit some years ago, from a tire that failed, that was plugged.....

pila
Donating Member
Donating Member

Street Cred : 43

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by chevellelaguna on Thu Sep 11, 2014 9:07 pm

We still plug tires....just not in a sidewall like that one. We wouldn't put 6 in a tire and let you leave.....unless it was your wife's car, and her insurance policy was paid up.
chevellelaguna
chevellelaguna
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 16

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Thu Sep 11, 2014 9:43 pm

The last place I worked at that plugged tires sold out in 1996.  I didn't think anyone (business) still plugged tires for liability reasons.
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by chevellelaguna on Thu Sep 11, 2014 11:11 pm

I hear ya. I just do what the Boss tells me to
do.
chevellelaguna
chevellelaguna
G3GM Enthusiast
G3GM Enthusiast

Street Cred : 16

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Tue Mar 10, 2015 11:34 am

It only "just" started making noise! - Page 2 IMG_20150307_100949296_zpsdrorax7k
This came in on Saturday.... First tire I've ever seen with a dragons tail.
It only "just" started making noise! - Page 2 FB_IMG_1425826428042_zps8nixgrwm
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

It only "just" started making noise! - Page 2 Empty Re: It only "just" started making noise!

Post by dynchel on Thu Apr 02, 2015 7:09 pm

It only "just" started making noise! - Page 2 IMG_20150331_173038624_zpsiddc2py4
So this came in Tuesday with no brake pedal.... The rotor go so thin the piston came out of the bore.  No vehicle inspection in Ohio gives us entertaining pics like this.
dynchel
dynchel
Donating Member
Donating Member

Street Cred : 40

Back to top Go down

Page 2 of 3 Previous  1, 2, 3  Next

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum